Cruisers Forum

Main Forum => General Discussion => Topic started by: frecklestweety on February 19, 2013, 07:02:57 pm



Title: Sanitary Mascerator System didn't work right.
Post by: frecklestweety on February 19, 2013, 07:02:57 pm
First time out with motorhome and the pump did not work. So had to do the old method and was able to dump. The only problem with that my emergency hose I carried with me was not long enough, so off the walmart for a new system.  Had help from the campground owner...Will have to take mh to dealer and see what the problem was.   I was looking forward to using the system but at least the old way worked.  The test shows that the black water is still 1/3 full so there are some dirty sensors. Will need to clean it out when I get home.    Even Thetford couldnt help me.  Almost call a rv service but the campground owner and another rv camper helped out.  If you ever come to Williamsburg, Va a small family owned Anvil Campground are very accomodating.
 So what could have been the problem   


Title: Re: Sanitary Mascerator System didn't work right.
Post by: kevin on February 19, 2013, 07:19:46 pm
Hi, if you are up for crawling around down under, check the wires coming off the grinder for corrosion & possible failure. Do the ele. valves work?  Maybe the fuse is futzed.  I think you can turn the impeller with a screwdriver if it is jammed.  Good luck.
Oh, we have stayed at Anvil Campground and also enjoyed our stay.
kevin


Title: Re: Sanitary Mascerator System didn't work right.
Post by: frecklestweety on February 20, 2013, 09:29:51 am
Hi, if you are up for crawling around down under, check the wires coming off the grinder for corrosion & possible failure. Do the ele. valves work?  Maybe the fuse is futzed.  I think you can turn the impeller with a screwdriver if it is jammed.  Good luck.
Oh, we have stayed at Anvil Campground and also enjoyed our stay.
kevin
Thanks for advice.  I have Good sam warranty and service contracts and when I get home next week, I will take to my RV dealer.


Title: Re: Sanitary Mascerator System didn't work right.
Post by: JackD on February 21, 2013, 09:52:20 am
You might try turning the screw on the end of the pump - a few turns.  Sometimes they get jammed or stuck and turning the screw manually will clear it.  There is a rubber cover on the end of the pump which has to be removed to get to the screw.
Jack


Title: Re: Sanitary Mascerator System didn't work right.
Post by: frecklestweety on February 21, 2013, 06:56:14 pm
You might try turning the screw on the end of the pump - a few turns.  Sometimes they get jammed or stuck and turning the screw manually will clear it.  There is a rubber cover on the end of the pump which has to be removed to get to the screw.
Jack
Tried turning the screw. It only turns about 1/4".  I didn't want to force it anymore....I will have it checked out later. I can still dump the reg.way. Thanks


Title: Re: Sanitary Mascerator System didn't work right.
Post by: keelhauler on February 23, 2013, 08:00:00 am
That's your problem, something is stuck in the blades.

It can be turned in either direction. Sometimes if you turn it back and forth what ever is jammed in there will break. If not it probably something that was accidently dropped into the tank or sink drain when the RV was manufactured,

It's very simple to take the pump out. It just hooks on to the pipe the same way your serwer hose hooks on. Just unclamp the small hose and unplug the wires.
Hold it so inlet is down, tap it, turn screw back & forth and it should fall out.

The screw should always rotate freely if it is unplugged.


Title: Re: Sanitary Mascerator System didn't work right.
Post by: frecklestweety on February 23, 2013, 07:34:29 pm
That's your problem, something is stuck in the blades.

It can be turned in either direction. Sometimes if you turn it back and forth what ever is jammed in there will break. If not it probably something that was accidently dropped into the tank or sink drain when the RV was manufactured,

It's very simple to take the pump out. It just hooks on to the pipe the same way your serwer hose hooks on. Just unclamp the small hose and unplug the wires.
Hold it so inlet is down, tap it, turn screw back & forth and it should fall out.

The screw should always rotate freely if it is unplugged.
since I just purchased this motorhome, I am going to leave it to the rv dealer. thanks.


Title: Re: Sanitary Mascerator System didn't work right.
Post by: detspcl on March 07, 2013, 09:10:22 am
I too have a mascerator system that suffered a failure (twice). Both times it was a bad switch. During the second failure I was dumping during a severe storm. The lid covered switch/valve handles did not prevent rain spray from entering outside control panel. Does anyone know if the switch that controls the mascerator is waterproof????? If not, it should be.

chuck