Pages: [1]   Go Down
Print
Author Topic: GPS, Back Up Camera, Radio Dead,Dead, Dead!  (Read 497 times)
Bside60
Full Member
***

Helpful Rating: 1
________
OwnPC: Yes
NewUsed: New
PurchDate: Feb 2014
Model: 2350 Ford
ModelYear: 2014
Slide: Yes
IntColor: Cafe
ExtColor: Sunlit
Location: Colorado
________
Posts: 16



View Profile
« on: April 27, 2016, 06:55:47 pm »

Got my 2014 PC2350 out of storage. Truck battery was dead so had to jump start it. Everything else works fine but the GPS/Radio/ Back up camera is blank. Checked #14 fuse and it is still good. I would appreciate any thoughts or suggestions.

Thanks,

Bob Whiteside
Logged
bhgareau
Sr. Member
****

Helpful Rating: 41
________
OwnPC: Yes
NewUsed: New
PurchDate: 05/12
Model: 2400 Ford
ModelYear: 2012
Slide: Yes
IntColor: dusk
ExtColor: sterling
Location: Alaska
________
Posts: 92



View Profile
« Reply #1 on: April 28, 2016, 12:14:56 am »

This same thing happened to my rig several years back. It is a Ford fuse and I don't remember which one. Give Kermit a call at the factory and he will tell you which one.
Logged
Bside60
Full Member
***

Helpful Rating: 1
________
OwnPC: Yes
NewUsed: New
PurchDate: Feb 2014
Model: 2350 Ford
ModelYear: 2014
Slide: Yes
IntColor: Cafe
ExtColor: Sunlit
Location: Colorado
________
Posts: 16



View Profile
« Reply #2 on: April 28, 2016, 10:45:04 am »

I'll give him a call today. that would be great if it was simply a blown fuse!

Thank you,

Bob
Logged
bhgareau
Sr. Member
****

Helpful Rating: 41
________
OwnPC: Yes
NewUsed: New
PurchDate: 05/12
Model: 2400 Ford
ModelYear: 2012
Slide: Yes
IntColor: dusk
ExtColor: sterling
Location: Alaska
________
Posts: 92



View Profile
« Reply #3 on: April 28, 2016, 09:40:39 pm »

I found my notes from my conversation with Kermit. It was a 40 amp Ford fuse #12. I also have a reference to p222 of the owners manual. Good luck!
Logged
Pages: [1]   Go Up
Print
 
Jump to: