Pages: [1]   Go Down
Print
Author Topic: New truck battery  (Read 1464 times)
GoPhoenix
Hero Member
*****

Helpful Rating: 75
________
OwnPC: Yes
NewUsed: New
PurchDate: 12/2010
Model: 3100
ModelYear: 2011
Slide: Yes
IntColor: Slate grey/Cherry
ExtColor: Full body grey
Location: Ohio
________
Posts: 282



View Profile
« on: February 26, 2015, 08:06:53 am »

I may have to replace my truck battery.  It was totally dead, and Im trying to charge it.  In looking for a replacement (Advance Auto and AutoZone the only stores in our little town), I found at Advance Auto: AutoCraft Silver Battery, Group Size 65, 750 CCA, $131.99, good reviews.  The specs say Auxiliary Battery; Requires special deep cycle battery.  My question is: is the original battery I have now considered a deep cycle battery?  Should I have the charger setting on Deep Cycle?
Logged

I remember very few of the things that Ive spent money to buy, but I remember all of the places that Ive spent money to see.
KB9OMH
Hero Member
*****

Helpful Rating: 42
________
OwnPC: Yes
NewUsed: New
PurchDate: 3/26/13
Model: 3100
ModelYear: 2013
Slide: Yes
IntColor: Maple
ExtColor: Sterling
Location: IL
________
Posts: 143


View Profile
« Reply #1 on: February 26, 2015, 08:59:01 am »

Gary,
     As a rule you don't use a deep cycle battery for a starting battery, but the spec. on this battery does say it has the cca being good, the review I read were both good and bad.

Jim
KB9OMH
Logged
keelhauler
Hero Member
*****

Helpful Rating: 103
________
OwnPC: Yes
NewUsed: New
Model: 2552
ModelYear: 2012
Slide: Yes
IntColor: Sunlit Maple
ExtColor: Sunlit - no paint
Location: Westlake, OH
________
Posts: 282



View Profile WWW
« Reply #2 on: February 27, 2015, 08:31:00 am »

I don't understand "Truck Battery".

Do you mean the 2 RV batteries or the Engine battery under your hood?

The 2 are Deep Cycle but the engine battery is a standard car battery.

All lead acid batteries are charged at the same voltage.
Logged

GoPhoenix
Hero Member
*****

Helpful Rating: 75
________
OwnPC: Yes
NewUsed: New
PurchDate: 12/2010
Model: 3100
ModelYear: 2011
Slide: Yes
IntColor: Slate grey/Cherry
ExtColor: Full body grey
Location: Ohio
________
Posts: 282



View Profile
« Reply #3 on: February 28, 2015, 05:49:35 am »

I mean the Ford truck battery, not the two deep cycle coach batteries.
Logged

I remember very few of the things that Ive spent money to buy, but I remember all of the places that Ive spent money to see.
keelhauler
Hero Member
*****

Helpful Rating: 103
________
OwnPC: Yes
NewUsed: New
Model: 2552
ModelYear: 2012
Slide: Yes
IntColor: Sunlit Maple
ExtColor: Sunlit - no paint
Location: Westlake, OH
________
Posts: 282



View Profile WWW
« Reply #4 on: February 28, 2015, 07:36:04 am »

So any standard car battery of the same group size is fine. Interstate is a good brand,
Logged

bobojay
Hero Member
*****

Helpful Rating: 18
________
OwnPC: No
NewUsed: New
Model: None
Slide: No
IntColor: Desert Sand-Hickory
ExtColor: Desert Sand-Lower
Location: Kansas
________
Posts: 102


View Profile
« Reply #5 on: February 28, 2015, 08:48:55 pm »

If you buy from Advanced Auto, be sure to go online and grab one of their coupons from their website.
It can save some real $$$$. And check the battery mfg date so you don't buy one more than a couple months old
Logged

Bob & Sharon
Current: 2013 Winnebago ERA Class B Sprinter Van
Future: 2100 special, 2350, ?? on a hopefully Ford Transit 350 or 450
GoPhoenix
Hero Member
*****

Helpful Rating: 75
________
OwnPC: Yes
NewUsed: New
PurchDate: 12/2010
Model: 3100
ModelYear: 2011
Slide: Yes
IntColor: Slate grey/Cherry
ExtColor: Full body grey
Location: Ohio
________
Posts: 282



View Profile
« Reply #6 on: February 28, 2015, 08:56:34 pm »

Well, that doesnt really address my question about the Advance Auto AutoCraft Silver Battery and why the specs say Auxiliary Battery; Requires special deep cycle battery when it is advertised as an exact replacement for a Ford E450 (Advance Auto and AutoZone the only stores in our little town).

It may a moot point now as the battery finally took a charge.  But now a new problem.  After disconnecting the battery, cleaning the terminals, reconnecting and charging, the review camera monitor stays on even with the ignition turned off.  The compass and thermometer in the rearview mirror also stay on.  Very weird.  Suggestions from anyone?
Logged

I remember very few of the things that Ive spent money to buy, but I remember all of the places that Ive spent money to see.
keelhauler
Hero Member
*****

Helpful Rating: 103
________
OwnPC: Yes
NewUsed: New
Model: 2552
ModelYear: 2012
Slide: Yes
IntColor: Sunlit Maple
ExtColor: Sunlit - no paint
Location: Westlake, OH
________
Posts: 282



View Profile WWW
« Reply #7 on: February 28, 2015, 10:13:41 pm »

The switch next to the steering wheel that allows you to charge your engine battery may still be on, it makes my step go in when it is on and door closed.
Logged

Dutch
Full Member
***

Helpful Rating: 3
________
OwnPC: Yes
NewUsed: Used
PurchDate: March 2014
Model: 2551
ModelYear: 2011
Slide: Yes
IntColor: Cherry
ExtColor: Sage/White
Location: Northern California
________
Posts: 10


View Profile
« Reply #8 on: March 01, 2015, 04:32:29 pm »

Last week I had to replace the engine battery in my 2011 model 2551. It had been in storage for the winter and wouldn't crank. I had to jump start it to bring it the 10 miles to home. When I turned off the engine, I noticed the fuel gauge jumped to beyond full and the back up camera stayed on. The next morning, it just barely started so I took it to a local auto/truck service center where they tested the battery. It was too far gone to hold more than a 10% charge. Replaced it with a new Interstate 750cca battery and my fuel gauge and camera problems disappeared. Evidently, proper the functioning of certain gauges and options in the RV are affected by low battery output. Not sure but it seemed that way in my case.
Logged
GoPhoenix
Hero Member
*****

Helpful Rating: 75
________
OwnPC: Yes
NewUsed: New
PurchDate: 12/2010
Model: 3100
ModelYear: 2011
Slide: Yes
IntColor: Slate grey/Cherry
ExtColor: Full body grey
Location: Ohio
________
Posts: 282



View Profile
« Reply #9 on: March 01, 2015, 06:46:31 pm »

Wow, keelhauler.  If you were here, Id give you a big kiss; well at least firm handshake.  The switch was on (from trying to start the engine).  After turning it off, the compass/thermometer in the rearview mirror, the rearview camera, and the step, all starting working correctly!  I did give you a helpful vote.  Great.   ThumbsUp
Logged

I remember very few of the things that Ive spent money to buy, but I remember all of the places that Ive spent money to see.
Pages: [1]   Go Up
Print
 
Jump to: