Pages: [1]   Go Down
Print
Author Topic: Auto-Drain Valves on waste tanks  (Read 1783 times)
Phoenix
Full Member
***

Helpful Rating: 3
________
OwnPC: Yes
NewUsed: New
PurchDate: January 2007
Model: 2910
ModelYear: 2910/2007
Slide: Yes
IntColor: Green
ExtColor: White
________
Posts: 10


View Profile
« on: April 21, 2009, 02:47:32 am »

Hi Help
The auto-drain valves for the waste tanks on my 2002 29ft Cruiser are not working Cry
There is no light displayed when the switches are operated. Are there fuses or breakers in the circuit which could possibly be the problem and where are they located? Unfortunately living in the UK there are very few dealers who are able to assist including the company that imported the RV into the country for me!
Thanks in anticipation
Chris
Logged
Phoenix
Full Member
***

Helpful Rating: 3
________
OwnPC: Yes
NewUsed: New
PurchDate: January 2007
Model: 2910
ModelYear: 2910/2007
Slide: Yes
IntColor: Green
ExtColor: White
________
Posts: 10


View Profile
« Reply #1 on: April 21, 2009, 03:34:10 am »

HiThere me again
Oops the Cruiser is a 2007 model, the 2002 is my Grand Vitara toad. A 'senior moment' Embarrassed
Chris
Logged
Ajarand
Jr. Member
**

Helpful Rating: 3
________
________
Posts: 8


View Profile
« Reply #2 on: April 21, 2009, 04:57:59 pm »

I had the same problem on my 2006 PC.  For about 12 dollars each, I replaced the electric valves with manual valves. Took less thanb an hour to make the change and they really are not that much harder to reach and open... Plus, we sometimes use our unit in winter and electric valves seem to be 'iffy' at best during cold weather.
Alan Jarand
Logged
Pages: [1]   Go Up
Print
 
Jump to: