Cruisers Forum

Main Forum => General Discussion => Topic started by: retdep on June 22, 2018, 03:37:40 pm

Title: HWH Leveler Problem
Post by: retdep on June 22, 2018, 03:37:40 pm
I have a 2016  Model 2351, purchased used.
Leveling system worked just fine until 2 days ago.  AARRGGH
3 of the jacks will deploy as they should before they extend to level vehicle.  The Driver Side Front will not deploy from horizontal to vertical position. 
I can get it to vertical by hand and hold it there and then when auto button is pressed for 3rd time (to start the leveling process) things will operate as they should.  Vehicle will auto level.
No problems with retraction.
Thoughts?
We are currently enroute to Alaska, so my internet availability is limited.  I may not be able to respond rapidly.
Title: Re: HWH Leveler Problem
Post by: ron-n-toni on June 22, 2018, 05:00:51 pm
Had trouble of a different kind with my jacks and took it to the installer in Elkhart that does the work for Phoenix. He told me the biggest problem with jacks is dirt.  He told me to wipe them down, spray with WD-40, Wipe clean and spray again.If you are  on the Alcan, I'm sure your jacks are dirty. Might try cleaning and lube.
Title: Re: HWH Leveler Problem
Post by: fandj on June 22, 2018, 05:46:54 pm
This document from HWH  might be useful if your problem relates to dirty jacks.


https://www.hwhcorp.com/ml47149.pdf (https://www.hwhcorp.com/ml47149.pdf)
Title: Re: HWH Leveler Problem
Post by: Joseph on June 23, 2018, 09:11:45 am
Have you checked your fluid level?
Title: Re: HWH Leveler Problem
Post by: jfcaramagno on June 30, 2018, 07:45:53 pm
Fandj, I can't read your document. Safari says it is empty.
Title: Re: HWH Leveler Problem
Post by: Barry-Sue on July 02, 2018, 06:20:24 pm
Have you  visually inspected the jack?  This past winter our driver side rear jack would not deploy.  Upon close inspection I noticed that the actuator cable had broken.  Its main function is to deploy the jack down.  I was close to a camping world and they ordered the part from HWH.  Our part number was RAP7194 (actuator cable kit).  With shipping to the store it was $40.

Got it fixed and then a week later the passenger side rear jack needed the same replacement.

Here is a link to the parts diagram.  We have the HWH kick down jack on our 2012.  I also called HWH to verify the part number.  https://www.hwhcorp.com/ml11428.pdf#page390